Welcome, Guest
Username: Password: Remember me

TOPIC: Problems with Joomla 3.8.13

Problems with Joomla 3.8.13 1 year 5 days ago #1

  • ntm
  • ntm's Avatar
  • OFFLINE
  • New Member
  • Posts: 4
Hello,
Since the version Joomla 3.8.13 my overrides do not work anymore. Especially the controllers of com_users not.
Where can the mistake be?
The administrator has disabled public write access.

Problems with Joomla 3.8.13 1 year 4 days ago #2

  • sdic
  • sdic's Avatar
  • OFFLINE
  • Developer
  • Posts: 73
Hello,

As mentioned by email, we have make some tests this morning with a Joomla 3.8.13 and the plugin MVC Supersede 1.1.1
The override works well for us (controller com_users).

So we need more information to help you.
We think that something has been changed after the update of your side if the override worked fine before and not now.

  1. Do you have installed the MCV Supersede 1.1.1 ?
  2. Do you have update your template ? (that contain the folder with override)
  3. The server environment has been modified ?
  4. Do you have any errors on your Apache log ?
  5. What happend when you debug you controller override ? if you die on the begin of the function (controller overrided, by exemple public function register() ), do you see the die ?
  6. If you compare the orignal version of controller, except the override modifications there is another change ? if yes copy/past the controller original in your override folder and complete with your override process to be sure that have the same controller.

Thanks in advance, best regards
SDIC Support Team
The administrator has disabled public write access.

Problems with Joomla 3.8.13 11 months 4 weeks ago #3

  • ntm
  • ntm's Avatar
  • OFFLINE
  • New Member
  • Posts: 4
Yes, I have MCV Supersede 1.1.1 installed.

What happens is the following.
1. The user is registered
2. The user gets an email with a confirmation link.
3. He presses on the link and nothing happens anymore.

The only change was the update from 3.8.12 to 3.8.13

The server environment has been modified ? NO
Do you have any errors on your Apache log ? NO
The administrator has disabled public write access.

Problems with Joomla 3.8.13 11 months 4 weeks ago #4

  • sdic
  • sdic's Avatar
  • OFFLINE
  • Developer
  • Posts: 73
Hello,

With our tests all work fine... so the version 1.1.1 works fine with Joomla 3.8.13.

During our test, the link open the right view, the function activation (controller) has been called normally and the user has been activate with success.

Just in case, please check your user manager option (backend) to check is the parameter "New User Account Activation" is set to "self"

When you said "He presses on the link and nothing happens anymore." -> what happens eaxctly ?
The link open the website ? on the right view/page ? the registration email sent to the user contain a correct activation link ?

And into you controller the function "activate" is called when you click on the activation link ? (make a die and test with a valid activation link)

Thanks in advance, best regards
SDCI Support Team
The administrator has disabled public write access.

Problems with Joomla 3.8.13 11 months 4 weeks ago #5

  • ntm
  • ntm's Avatar
  • OFFLINE
  • New Member
  • Posts: 4
Hello,
The setting to enable user is set.

If the user clicks on the activation link, the page is opened but you do not get the message that the administrator will be notified to unlock the account.

But it opens only the page without any hint.

Did you also test the whole thing with my files? Otherwise you could send me your test files.
Email Adresse: This email address is being protected from spambots. You need JavaScript enabled to view it.
The administrator has disabled public write access.

Problems with Joomla 3.8.13 11 months 4 weeks ago #6

  • sdic
  • sdic's Avatar
  • OFFLINE
  • Developer
  • Posts: 73
Hello,

We have sent an email to you with our test files (com_users controller + model) with the instructions.

Best regards
SDIC Support Team
The administrator has disabled public write access.

Problems with Joomla 3.8.13 11 months 4 weeks ago #7

  • ntm
  • ntm's Avatar
  • OFFLINE
  • New Member
  • Posts: 4
Hello,
I have integrated your files and get the following message.
activation - controller
Otherwise nothing is going for a walk.
What do I have to do to keep my function running?

It's been dealt with. I found what you meant.

Thanks for your help.
Last Edit: 11 months 4 weeks ago by ntm.
The administrator has disabled public write access.

Problems with Joomla 3.8.13 11 months 4 weeks ago #8

  • sdic
  • sdic's Avatar
  • OFFLINE
  • Developer
  • Posts: 73
Hello,

Ok good, so if you have seen the message "activation - controller" that meant that the override works fine like on our side.

If your function strop their process it's certainly due from a check that is false and go out the function.
So now you can debug step by step (move the "die" and dump/check the data) trough the function "active" and search where your process stop.

Best regards
SDIC Support Team
The administrator has disabled public write access.
Moderators: sdic
Time to create page: 0.085 seconds